Apogee FX Rack Pultec EQP-1A Program Equalizer

$199.00
Write a Review
SKU:
Apogee-1143-851
Condition:
New
Shipping:
Free Shipping
reverb_sync:
on
Apogee FX Rack Pultec EQP-1A Program Equalizer (Apogee-1143-851)

Apogee FX Rack Pultec EQP-1A Program Equalizer || Your Software Registration Code and Instructions Will Be Sent to You, Along With an URL Connecting You Directly to The Manufacturer, Who Will Provide You With Your Software. We are Authorized Apogee Resellers. Verify Our Credentials on the Xchange Market. Please Be Aware That Software Is Non-Cancelable and Non-Returnable. If you have any questions about this product please do not hesitate to contact us.

EQP-1A Program Equalizer
AU/VST/AAX

In our obsessive quest to reproduce every nuance of the Pultec Program Equalizer, we had a worthy partner Steve Jackson of Pulse Techniques, the current manufacturer of new Pultec hardware.  After careful analysis of several vintage and new Pultec EQP-1A units, Apogee chose to model our plugin after one of Steve’s new units it was like unboxing a brand new unit in 1959.

Highlights

  • Precisely recreates the Pultec EQP-1A’s unique characteristics
  • Broad EQ curves, to gently but powerfully shape your sounds while maintaining their integrity
  • Interaction of Bands, to create characteristic EQ curves used by engineers for decades
  • Circuit Non-Linearites, to add the “magic” that hardware units are renown for
  • Developed with Pulse Technologies, current manufacturer of hardware Pultec EQs
  • Apogee plugin modeled from brand new Pultec unit
  • Officially Licensed and Endorsed by Pulse Techniques
  • Run natively in your favorite DAW on your Mac, no Apogee hardware required
  • Runs on Apogee hardware DSP in Element Series and Ensemble Thunderbolt audio

System Requirements

  • Mac OS X 10.12.6 or higher – 10.14 Mojave fully supported
  • 4 GB minimum RAM, 8 GB or higher recommended
  • Free Pace iLok account – physical iLok not required

 

Supported DAWs

  • Logic Pro 10
  • Pro Tools 12, Ultimate (ProTools 11 and lower not currently supported )
  • Ableton Live 10
  • Cubase 9.5  VST 1 & 2  (VST 3 not implemented in this release )
  • Please note that any AUv2, VST 1&2m, or AAX fully compliant DAW should work

Videos Hide Videos Show Videos